Vulnerability Details : CVE-2022-30292


CVE Name: CVE-2022-30292: Memory Corruption vulnerability on Squirrel Lang Squirrel, Fedoraproject Fedora
Description: Heap-based buffer overflow in sqbaselib.cpp in SQUIRREL 3.2 due to lack of a certain sq_reservestack call.
Publish date: 2022-05-04T23:15Z
Last Update: 2022-07-22T10:24Z

CVSS Scores & Vulnerability Types


CVSS Score
Confidentiality ImpactHIGH
Integrity ImpactHIGH
Availability ImpactHIGH
Actack VectorNETWORK
Actack ComplexityLOW
Privileges RequiredNONE
User InteractionNONE
ScopeCHANGED
Vulnerability Type(s)Memory Corruption
CWE ID787

Products Affected By CVE-2022-30292


# Vendor Product Vulnerable Versions
1 Squirrel Lang Squirrel 1
2 Fedoraproject Fedora 2

Detail of Verions Affected


# Product Type Vendor Product Version
1 Application Squirrel Lang Squirrel 3.2
2 Operating System Fedoraproject Fedora 35
3 Operating System Fedoraproject Fedora 36